Teams Phone Number Porting Issue

Incident Report for SMS

Update

Microsoft are continuing to investigate this issue.
Posted Sep 02, 2025 - 14:52 BST

Investigating

Due to a technical issue with Microsoft's partner, phone number porting in, new number acquisition and other number related operations in most of our European markets are currently unable to proceed ion Microsoft Teams Phone.

Their partner is actively working to resolve the issue, and affected orders will be processed or rescheduled to the next available dates once resolution is confirmed.

This does not have any impact on any other Microsoft or Office 365 service
Posted Aug 29, 2025 - 09:43 BST